Stabilizing measures
Incident Report for agrirouter system
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 10:21 CEST
Update
General system availability seems to have stabilized. The measures taken and mentioned below will remain active until further notice to ensure continued stability.
Posted Jun 03, 2024 - 06:57 CEST
Update
The restarts are currently done only every *other* hour, so on 2:05, 4:05, 6:05, etc. according to CEST.

We are adding a few more IP addresses to our block list, so again the reminder:
** If you feel you might have been affected by an IP address block, please contact us for details, providing your own outgoing IP address(es) at support@my-agrirouter.com **
Posted May 30, 2024 - 14:46 CEST
Update
We have identified IP addresses that are spamming the system with connection requests.
As we currently have no means to tie these IP addresses to specific applications, we will start blocking those IP addresses.
** If you feel you might have been affected by this block, please contact us for details, providing your own outgoing IP address(es) at support@my-agrirouter.com **
Posted May 15, 2024 - 13:28 CEST
Identified
As a temporary mitigation of the problems we currently see, the IoT gateway of agrirouter will be restarted every hour at :05 minutes.
The restart will take ~60 seconds.
Established connections will be dropped and no new connections accepted until the restart is completed, for both HTTP and MQTT clients.
Push Notifications might not be delivered reliably if new messages would be signaled in the time between, but messages would still be retained in the feed and can be retrieved via the respective API call.

This measure will allow us to solve the root cause of the problem.
Posted May 14, 2024 - 10:44 CEST
This incident affected: agrirouter.